Como crear una VLAN

COMO CREAR UNA VLAN

Para crear una Vlan tenemos que acceder al modo administrador con el comando “enable”. Los comandos que veremos a continuación no están completos, recordemos que el IOS de Cisco reconoce los comandos aunque no estén completamente escritos. Una vez en modo administrador, accedemos a la configuración global “configure terminal”, en el ejemplo sólo he puesto “conf t” y ya accedemos, si queremos nos podemos ayudar del tabulador para que el sistema termine de escribir el comando por nosotros o utilizar el signo “?” para que nos ofrezca todas las opciones.

Switch>enable

Switch#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#vlan 10

Switch(config-vlan)#name <nombre de la Vlan>

Switch(config-vlan)#ex

 

La Vlan está creada y nombrada, pero no está configurada, para ello debemos ir a cada interfaz del switch que tenga una conexión. En el ejemplo utilizaremos las interfaces fa0/1, fa0/2 y fa0/3.

Las interfaces fa0/2 y fa0/3 estarán conectadas a un PC y la fa0/1 estará conectada a un router (también podría estar conectada a otro Switch).

Los comandos para configurar las interfaces que van a los PC´s son los siguientes:

MODO ACCESO

Switch(config)#interface fa0/2

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 10

 

Switch(config)#interface fa0/3

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 10

 La interfaz fa0/1 debe admitir todas las VLAN´s de toda la red, o de todas aquellas que nosotros queramos que tengan conectividad, para ellos NO la configuraremos en modo acceso, la configuramos en modo troncal.

 

Switch(config)#interface fa0/1

Switch(config-if)#switchport mode trunk

Switch(config-if)#switchport trunk allowed Vlan 10,20,30

Switch(config-if)#switchport trunk native

Switch(config-if)#switchport trunk native vlan 99

Switch(config-if)#exit

 

Con el primer comando, le decimos que configure la interfaz en modo troncal, para que puedan pasar todas las VLAN´s.

Con el segundo comando “allowed” le decimos que VLAN´s tienen permiso para pasar. En este caso autorizo a la VLAN 10, a la 20 y a la 30. Si tuviéramos más, simplemente se pone “,” y otra VLAN.

Con el tercer comando le digo al Switch que la VLAN nativa la cambio y que a partir de ahora es la 99 en lugar de ser la VLAN 1.

 

Con estos comandos es suficiente para configurar VLAN´s, hayan 3 interfaces o 30. Las interfaces que estén conectadas a un PC, se configurarán en modo ACCESS y las que estén conectadas a otro Switch o a un router, se configurarán en modo TRUNK.

 

Si hacemos esta configuración en una topología de dos switches, un router y 3 PC´s por cada Switch, sólo tendremos conectividad entre los PC´s de la misma VLAN. Entre VLAN´s no tendremos conectividad porque necesitamos un Switch de 3 capas o un router.

 

 

Configuración del Router (router-on-a-stick)

 

Router-on-a-stick es un tipo de configuración del router en el que una única interfaz física encauza todo el tráfico entre las distintas VLANs de una red. Para esta configuración es necesario crear subinterfaces en la interfaz del router.

 

Desde configuración global del router:

 

Router(config)#interface fa0/0.10 (para crear una subinterfaz, ponemos “.” Después de la interfaz y escribimos el número de la subinterfaz)

Router(config-subif)#encapsulation dot1Q 10 (comando de modo de encapsulación)

Router(config-subif)#ip address 192.168.0.1 255.255.255.0 (IP y mascara de subred de cada VLAN)

 

Router(config)#interface fa0/0.20

Router(config-subif)#encapsulation dot1Q 20

Router(config-subif)#ip address 192.168.0.1 255.255.255.0

 

Router(config)#interface fa0/0.30

Router(config-subif)#encapsulation dot1Q 30

Router(config-subif)#ip address 192.168.0.1 255.255.255.0

 

Una vez finalizada la configuración del router, tendremos conectividad inter-VLAN, hacemos ping de un PC a cualquier otro para verificar la conectividad.

 

Descargar el artículo en PDF

 

 

 

 

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s